WordPress:PHP7.3にアップグレードでjetpack関連でエラー”continue” targeting switch is equivalent to “break”.と出る

記事公開日:
最終更新日:

This post is also available in: 英語

PHP7.3にアップグレードすると、Jetpack関連で以下のようなエラーが、ページをロードした際に瞬間的に表示されるようになりました。
備忘録的に対処法などをメモ書きしています。

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in .../wp-content/plugins/jetpack/_inc/lib/class.media-summary.php on line 77
Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in .../wp-content/plugins/jetpack/_inc/lib/class.media-summary.php on line 87

原因としては、古いバージョンのJetpackを使っていることが理由のようです。

なので、対処法としては、Jetpackのバージョンを上げれば解決しますが、場合によっては先にWordpressのアップグレードを行う必要があります。
どうしても、Wordpressのバージョンを上げる事ができない場合には、Jetpackのプラグインを停止することでエラーは出なくなると思います。

About
Amelt.net,LLCの創業者で、費用対効果の高い統合webマーケティングによりビジネスパートナーとして継続的にサポート。詳しいより。ブログの更新情報TwitterLinkedIn、またRSSfeedlyにてお知らせしていますのでフォローよろしくお願い致します。